Which operating systems are supported?

Apple

Google Chrome

  • Mac OS X 10.6 or later
  • Intel processor (64-bit)
  • 350 MB of free disk space
  • 512 MB of RAM

Mozilla Firefox

  • Firefox no longer works with Mac OS X 10.5
  • Firefox 16 is the last version of Firefox that works on Mac OS X 10.5 (Leopard). We recommend upgrading your computer or operating system for maximum online safety
  • Firefox no longer works with Mac OS X 10.4 or PowerPC processors
  • Firefox 3.6.28 is the last version to work on Mac OS X 10.4 or on Mac OS X 10.5 with a PowerPC Mac. We recommend a newer computer for maximum online safety
  • Firefox 3.6 is no longer supported
  • Firefox 3.6 will not be updated with security and stability fixes. We recommend that you install the latest Firefox version for maximum online safety

Safari

  • Safari 9.0
  • Intel, 64-bit processor
  • OS X 10.10 or later: Safari 7.1.8 (OS X 10.9), Safari 6.2.8 (OS X 10.8), Safari 6.1.6 (OS X 10.7.5), Safari 5.1.10 (OS X 10.6.8)

Microsoft

Google Chrome

  • Windows XP Service Pack 2+ (until the end of 2015), Windows Vista, Windows 7, Windows 8 or Windows 10
  • Intel Pentium 4 processor or later (SSE2 capable)
  • 350 MB of free disk space
  • 512 MB of RAM

Mozilla Firefox

  • Firefox no longer works with some versions of Windows XP
  • The latest Firefox does not work with the original version of Windows XP and Windows XP Service Pack 1 (please contact Microsoft for upgrade options)
  • Firefox no longer works with Windows 2000
  • Firefox 3.6.28 and Firefox 12 are the last versions that will work with Windows 2000. We recommend that you upgrade Windows and install the latest Firefox

0 Comments

Add your comment

E-Mail me when someone replies to this comment